Jump to content

Capture one Katalog "Sammlung enthält keine Bilder"


pflaf
 Share

Recommended Posts

Werbung (verschwindet nach Registrierung)

Hallo zusammen,

 ich bin gerade etwas am Verzweifeln:

Ich habe vor einigen Tagen meine RAW Dateien auf der Festplatte verschoben, weil ich die Ordnerstruktur verändert habe. Heute habe ich C1 geöffnet, die Bilder über die Finden-Funktion wieder an das Programm übergeben, ein Bild bearbeitet und C1 wieder geschlossen. Dabei kam das übliche Fenster, dass ich mal wieder ein Backup machen sollte. Das hab ich bestätigt aber eine Fehlermeldung erhalten. ("Es ist ein Fehler aufgetreten" oder so ähnlich, jedenfalls absolut nicht aussagekräftig.) Ich habe weiter versucht das Backup durchzuführen aber irgendwann aufgegeben und das Programm geschlossen. (Es hat sich dann erstmal aufgehängt, sodass ich das Schließen erzwingen musste, was im Nachhinein gesehen vermutlich meine ganzen Probleme verursacht hat...) Als ich es wieder geöffnet habe, musste ich feststellen, dass jede Menge Bilder fehlen, meine Ordnerstruktur sieht jetzt streckenweise so aus:

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

C1 scheint hier sämtliche Bearbeitungen im Katalog gelöscht zu haben. Die RAWs liegen weiterhin in den entsprechenden Ordnern. Mit der Finden-Funktion komme ich hier natürlich nicht weiter, da ich ja im Katalog scheinbar keine Bilder mehr habe, denen ich die zugehörigen RAWs zuordnen kann.

Interessant wird es, wenn ich in die Benutzersammlungen schaue. Ich habe hier ein intelligentes Album angelegt, in denen Teile der verlorenen Bilder noch aufzufinden sind. Die Bilder sind hier mit dem Fragezeichen gelistet, das immer auftaucht, wenn die RAWs  "offline" sind. Wenn ich hier die Finden Funktion anwende, tauchen die Bilder auch wieder in den normalen Ordnern auf. Das Problem ist aber, dass ich nicht alle Bilder in einem Album habe, und dass ich die Bilder, die in den Alben stecken einzeln über die Finden Funktion zuordnen muss.

Wenn ich in den jeweiligen Ordnern die synchronisieren Funktion verwende, werden die RAWs gefunden und die Bilder wieder angezeigt, die Bearbeitungen sind aber weg. Ich glaube, dass die .comasc-Dateien noch im Katalog stecken, aber von C1 nicht mehr erkannt werden.

Gibt es da ein Lösung für? Ist das Problem eventuell bekannt? Ich kann gern auch noch weitere Bilder hochladen, falls die Erklärung nicht ausreichend war.

Link to post
Share on other sites

vor 2 Stunden schrieb pflaf:

C1 scheint hier sämtliche Bearbeitungen im Katalog gelöscht zu haben.

Das wird schwierig.

Der Katalog von Capture One ist eine SQLite Datenbank. Diese Datenbank kann mit entsprechenden Tools gelesen und wenn nötig auch verändert werden. Letzteres ist aber absolut kein Job für Laien, da muss man genau wissen was man tut. Auch ist das Problem, dass der Inhalt dieser Datenbank eher kryptisch ist und so ausgelegt ist, dass sich Capture One darin zurecht findet und nicht unbedingt der User.

Ich verwende das Tool DB Browser for SQLite. Das sieht folgendermaßen aus:

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

Der dargestellte Datensatz ZPATHLOCATION ist bewusst gewählt. Da schreibt sich C1 alle möglichen Pfade rein, auf welche es bei Import und Export zugreift. Da besteht eventuell der Funken einer Chance, einen Pfad zu identifizieren, welcher jetzt nicht mehr existiert und welcher jetzt anders heißen sollte. Ob es noch Sinn macht, da herum zu biegen, wenn man schon soviel verändert hat, kann ich nicht beurteilen. Kann sein, dass es besser wird, kann sein dass es schlechter wird. Auf jeden Fall den aktuellen Katalog sichern oder einen früher gesicherten Katalog verwenden. Wenn Capture One nur in seiner eigenen Datenbank jongliert hat und keine echten Daten auf der Platte verschoben hat, dann könnte ein älterer Katalog sogar die bessere Option sein, weil da noch die alten Pfade drin stehen und gegen die neuen Pfade ausgetauscht werden können. Wie gesagt, wenn man sich das zutraut.

Der Speicherort für die Katalogbackups sollte etwa so aussehen:

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

Sollte dich die Frage quälen, ob deine comask Dateien noch da sind, die sollten in einem Pfad Adjustments - LAM - Jahr - Monat - Tag und einer Zahl gespeichert sein. Aber wenn du weißt, dass es comask Dateien gibt, dann weißt du wohl auch, wo sie zu Hause sind.

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

Das ist jetzt alles ein wenig im Schnelldurchlauf. Solltest du keine einfacher umzusetzenden Hinweise erhalten. dann kann man noch ein wenig ins Detail gehen.

Ich selbst habe mir schon lange abgewöhnt, den Capture One Support zu belästigen, aber das würde ich an deiner Stelle auch noch versuchen, bevor ich zu so einem scharfen Messer greife.

Edited by tengris
Link to post
Share on other sites

@pflaf, hast Du ein „gutes“ Backup der Datenbank?

ich würde die Dateien (die genannten RAW-Dateien ) wieder in ihre ursprünglichen Ordner zurück verschieben und das letzte Backup vor der Verschiebe-Operation zurück spielen.

Und hoffen, dass das letzte Backup erst kurz vor dem Problem- Zeitpunkt gezogen wurde.

Viele Grüße 

Edited by FranzMH
Link to post
Share on other sites

Danke für deine Antwort tengris! Nach einem kleinen Spaziergang ist mir noch ein Detail eingefallen das mir (glaube & hoffe ich) den A**** rettet. Ich war im Urlaub und habe dort auf dem Laptop einen neuen kleinen "Urlaubskatalog" angelegt in den ich unterwegs die Fotos importiert und grob bearbeitet habe. Da ich es für diesen Katalog versäumt habe, den Speicherort der RAWs außerhalb des Ordners zu definieren wurden die Bilder alle direkt in den Katalog importiert. Ich hatte mir die Filterfunktionen bis dato noch nicht genau genug angeschaut und habe mir deswegen für jeden Tag ein eigenes intelligentes Album angelegt. Diese intelligenten Alben wurden in meinen Hauptkatalog übernommen als ich den kleinen Katalog zu Hause in den Großen importiert habe. Die habe ich gerade gefunden und tatsächlich erinnert sich C1 an die Bilder und zeigt sie als "Die gewählte Datei ist entweder nicht verfügbar, besitzt ein nicht unterstütztes Format oder ist korrupt..." an. Mit der "Suchen..." Funktion kann ich die Bilder jetzt im Explorer suchen und den Pfad an C1 übergeben. Danach erscheinen sie wieder in bearbeiteter Form in den richtigen Ordnern.

Glück für mich, an die wirre C1 Ordnerstruktur möchte ich mich eigentlich nicht ranwagen...

vor einer Stunde schrieb tengris:

Sollte dich die Frage quälen, ob deine comask Dateien noch da sind, die sollten in einem Pfad Adjustments - LAM - Jahr - Monat - Tag und einer Zahl gespeichert sein. Aber wenn du weißt, dass es comask Dateien gibt, dann weißt du wohl auch, wo sie zu Hause sind.

Das sieht bei mir nämlich beispielsweise aus irgendeinem Grund etwas anders aus, bis zum Monat ists gleich, danach tauchen nur noch manche Tage auf, andere wiederum gar nicht. Danach geht es mit der zufälligen Zahl weiter. (Deren Sinn verstehe ich auch nicht, die sorgt nur dafür, dass ich in diesen Ordner nicht nachträglich RAWs einfügen kann, von denen ich möchte, dass sie von C1 "wiedergefunden" werden.)

In dem Bild sieht man beispielsweise die Bilder von diesem Mai, da fehlen im Vergleich zu dem Bild aus meinem Originalpost einige Tage. Warum das so ist kann ich mir nicht erklären, ich weiß nur, dass C1 damit scheinbar besser als ich zurecht kommt.

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

vor einer Stunde schrieb tengris:

Ich selbst habe mir schon lange abgewöhnt, den Capture One Support zu belästigen, aber das würde ich an deiner Stelle auch noch versuchen, bevor ich zu so einem scharfen Messer greife.

Das finde ich so schade, C1 ist ein Programm das mich eigentlich wirklich zufrieden stellt, aber sobald man mal Probleme hat, ist es immer ein riesen Problem. Hab schon drei/vier Mal im Dateiexplorer herumpfuschen müssen, das war jedes Mal ein riesen Act danach wieder alles zum Laufen zu bringen und die Tipps vom Suppoert bzw. dem Support Forum sind auch i.d.R. nutzlos.

vor einer Stunde schrieb FranzMH:

Und hoffen, dass das letzte Backup erst kurz vor dem Problem- Zeitpunkt gezogen wurde.

Im letzten Backup habe ich die betreffenden Bilder nicht gefunden und dachte deswegen es sei zu alt und ich müsste eine andere Lösung finden. Deswegen hatte ich den Thread eröffnet, aber ich hatte dort die intelligenten Alben übersehen, mit denen kann ich es jetzt hoffentlich retten.

 

Falls mir einer sagen kann wie ich die "Suchen..."-Funktion auf mehrere Bilder anwenden kann wäre ich zutiefst dankbar, das sind ca 1000 Bilder und mein PC hängt sich bei jedem Bild auf, da bin ich womöglich mehrere Stunden beschäftigt. Übergeordnete Ordner gibt es in dem Fall leider nicht und mehrere Bilder auswählen habe ich auch nicht hin bekommen...

 

 

Danke jedenfalls nochmal! Der Lerneffekt war noch häufiger Backups zu machen. Am Besten wäre wohl täglich....

Edited by pflaf
Link to post
Share on other sites

Oh eine Frage hat sich mir gerade noch aufgetan. Bevor ich herumprobiere und gleich den nächsten Problemlösungsthread öffnen muss: Wie sollte ich ein backup wiederherstellen, so dass ich keine Probleme bekomme? Ich habe jetzt auf der Suche nach dem richtigen Backup immer im Speicherort für Backups die entsprechenden Katalogdateien angeklickt und damit die zugehörigen Backupkataloge geöffnet.

Ich würde jetzt einfach den fehlerhaften Katalog mit allen zugehörigen Dateien löschen

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

und dann an diese Stelle den Backup Katalog mit den zugehörigen Dateien legen

Welcome, dear visitor! As registered member you'd see an image here…

Simply register for free here – We are always happy to welcome new members!

ist das ein sinnvolles Vorgehen oder gehen mir da gleich irgendwelche Sachen flöten?

Link to post
Share on other sites

Ich hatte das vor einiger Zeit gemacht. Ich bin mir jetzt nicht sicher und habe auch keine Testinstallation, die ich verwursten kann. Aber ich meine mich zu erinnern, dass wenn man ein Backup durch Anklicken der Katalogdatei öffnet, dieser Pfad dann zum aktuellen Katalogpfad wird und die weiteren Backups dann in diesem Pfad angelegt werden, wenn man diesen nicht zurück setzt. Wie gesagt ohne Gewähr. Ich würde aber meinen, wenn der aktuelle Katalog so korrupt ist, dass nicht einmal mehr ein Backup geht, dann wird sich die Freude damit in Grenzen halten. Ich Zweifelsfall kannst du ja den ganzen Katalogordner irgendwo sichern und später löschen, wenn du sicher bist, ihn nicht mehr zu benötigen.

Link to post
Share on other sites

Werbung (verschwindet nach Registrierung)

vor 13 Stunden schrieb tengris:

Ich Zweifelsfall kannst du ja den ganzen Katalogordner irgendwo sichern und später löschen, wenn du sicher bist, ihn nicht mehr zu benötigen.

So habe ich es jetzt gemacht. Scheint alles geklappt zu haben. Danke

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...