Jump to content
felix181

Topaz DeNoise AI

Recommended Posts

Werbung (verschwindet nach Registrierung)

vor 43 Minuten schrieb Ebi80:

Ich wollte mir zu Sharpen AI eigentlich auch noch Denoise AI anschaffen. Wenn ich mir aber die rauschfreien Bilder nach der Bearbeitung durch Sharpen ansehe, brauch ich das andere nicht mehr. Wenn das andersrum genauso aussieht, ist der Unterschied der beiden Programme lediglich die Ausrichtung der Hauptaufgabe. Mir wäre dennoch am liebsten Topaz würde beide Programme zusammenschmeißen.

Ich habe mir zuerst Denoise gekauft und jetzt Sharpen als Demo heruntergeladen. Sharpen werde ich mir kaufen. Denoise hätte ich, wenn ich Sharpen hätte, dann nicht mehr gekauft

Hänge mal ein Bild an das ich mit Denoise bearbeitet habe....

War das erste Bild, sicher werden manche von euch Verbesserungsvorschläge haben, ich persönlich bin aber sehr zufrieden!

 

Share this post


Link to post
Share on other sites
Am 9.12.2020 um 21:50 schrieb cyco:

Mein Topaz-Problem aus #384 ist quasi "gelöst", auch wenn ich nicht erklären kann warum. 😉 Aber hier noch mal beschrieben, vielleicht hilft es jemanden, der auch mal den Monitor und Kabel wechselt und Topaz nutzt.

Hierzu noch ein Nachtrag.

Ich habe mir jetzt einen neuen Rechner zusammengebaut und hatte das Problem, dass dieser neue Rechner, in dem aber meine Grafikkarte aus dem alten Rechner weiter verwendet wird, beim Starten keinen Startbildschirm des BIOS  gezeigt hat. Der Monitor hat erst ein Bild gezeigt hat, wenn Windows den Startbildschirm aktiviert hat. Verbunden sind Rechner und Monitor über ein Displayport-Kabel.

Per Zufallsfund habe ich dann entdeckt, dass es für viele Nvidia-Grafikkarte der 10er - Serie ein Update gibt, was Fehlverhalten mit dem Displayport behebt. Seitdem ich das Update eingespielt habe funktioniert alles. Ich vermute, dass meine Probleme mit Topaz die gleiche Ursache hatten. Wenn also jemand eine unten aufgeführte Karte nutzt und mal ein Problem mit der Displayport-Verbindung hat, erstmal checken ob die Firmware aktuell. Dafür einfach das Programme starten. Wenn die Firmare aktulisiert werden muss, sagst das Programm das und aktualisiert nach Bestätigung.

https://www.nvidia.com/en-us/drivers/nv-uefi-update-x64/

Share this post


Link to post
Share on other sites
Am 3.1.2021 um 22:10 schrieb tgutgu:

Der Preis liegt jedoch in der Verarbeitungsgeschwindigkeit.

Ich habe mir mal eine neue Grafikkarte spendiert (NIVIDIA RTX 2070 SUPER) und damit geht TOPAZ Denoise AI wirklich ratz fatz, dauert vielleicht 5 Sekunden pro Bild. Mit der alten Konfiguration war es deutlich länger.

Share this post


Link to post
Share on other sites
vor 8 Minuten schrieb tgutgu:

Ist diese GK laut und viel Strom verbrauchend?

Kaum zu hören, aber Strom saugt die wohl nicht zu wenig (bis zu 215W). Greta würde sagen "how dare you", aber dafür habe ich alle Lampen außer die meiner Studioblitze durch LED-Lampen ersetzt.

Edited by Rob

Share this post


Link to post
Share on other sites

Werbung (verschwindet nach Registrierung)

vor 5 Minuten schrieb ronsei:

Habe die gleiche Karte aber unter 30 Sekunden geht da nix bei mir mit Denoise.... 🤔

Seltsam... gerade noch mal gecheckt, ein 20 MP-Bild dauert im Denoising-Prozess etwa 5-6 Sekunden. GPU nicht bei Topaz aktiviert oder deutlich größere Dateien?

Share this post


Link to post
Share on other sites

Da ich trotz bereits längerer Verfügbarkeit vor Neugier beinahe gestorben wäre, habe ich mir das Testprogramm jetzt auch endlich geladen. Die 1030er Karte habe ich auch drin, es dauert leider auch etwas. Das liegt bei mir aber an der gesamten Rechnerkonfiguration noch mit W7. Aber es funktioniert trotz alledem überzeugend und überraschend gut - hätte ich nicht erwartet. Genug "Patienten" in meinen Sammlungen habe ich mehr als genug, auch für "low-light" - das Modul gefällt mir nach meinen drei Probefotos am Besten, sowohl in NEF (D3300) als auch in ORF (M1.2)

Allerdings ist das wohl kein Programm für jedes Foto. Der erste spontane Versuch hat das Foto auch mit sparsamen Arbeitswerten verschlechtert, es war allerdings kein ORF/NEF-RAW, sondern JPG aus einem NEF. Vllt. war das betreffende Foto im JPG auch schon ausgereizt, soll ja auch mal vorkommen 🤐

e - evtl. sollte ich dazu schreiben, dass ich mit split-screen original - preview ausprobiert hatte. Vllt. hat es auch damit zu tun, weil da quasi zwei Bilder parallel aufbereitet, bzw. vorgehalten werden müssen

Edited by rostafrei
Nachtrag

Share this post


Link to post
Share on other sites
vor 16 Minuten schrieb Rob:

Seltsam... gerade noch mal gecheckt, ein 20 MP-Bild dauert im Denoising-Prozess etwa 5-6 Sekunden. GPU nicht bei Topaz aktiviert oder deutlich größere Dateien?

Kommt nach meiner Erfahrung auf das Bild und die gewählte Methode an. 

Share this post


Link to post
Share on other sites
vor 9 Minuten schrieb cyco:

Kommt nach meiner Erfahrung auf das Bild und die gewählte Methode an. 

Ok, mag sein. Aber meine Erfahrung ist, dass eine schnelle Grafikkarte eine deutliche Beschleunigung mit sich bringt. Meine alte 560 Ti wurde von Topaz abgelehnt, da angeblich zu langsam. Jetzt mit der 2070 super bei sonst gleicher Konfiguration ist die Berechnung mindestens um den Faktor 10 schneller. 

Edited by Rob

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb rostafrei:

Allerdings ist das wohl kein Programm für jedes Foto. Der erste spontane Versuch hat das Foto auch mit sparsamen Arbeitswerten verschlechtert, es war allerdings kein ORF/NEF-RAW, sondern JPG aus einem NEF.

Die KI, die bei Topaz stärker ausgeprägt zu sein scheint als bei DeepPrime, vermutet manchmal Bildelemente, wo keine sind, und vertut sich dann bei der Extrapolierung der Kanten. Dann gibt es häßliche Artefakte. Aber wenn sie richtig geraten hat, ist sie schon gut.

Share this post


Link to post
Share on other sites
vor 7 Stunden schrieb Rob:

Seltsam... gerade noch mal gecheckt, ein 20 MP-Bild dauert im Denoising-Prozess etwa 5-6 Sekunden. GPU nicht bei Topaz aktiviert oder deutlich größere Dateien?

Datei ist um 25 MBYTE groß, GPU aktiviert.

Ist irgendwie auch egal welche Einstellungen ich bei Schärfe und Denoise gesetzt habe, braucht immer gleich lange.

5 Sekunden wären natürlich super, bin aber mit 30 auch sehr zufrieden! 🙂

Edited by ronsei

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb ronsei:

Datei ist um 25 MBYTE groß, GPU aktiviert.

Ist irgendwie auch egal welche Einstellungen ich bei Schärfe und Denoise gesetzt habe, braucht immer gleich lange.

5 Sekunden wären natürlich super, bin aber mit 30 auch sehr zufrieden! 🙂

Die schnelle Aktualisierung hat auch den Charme, dass der Auto-Preview problemlos angeschaltet bleiben kann. Bevor ich die neue GPU hatte, dauerte jedes Scrollen im Bild erstmal eine Weile, bis der Preview aktualisiert wurde. Das war wirklich mühsam, jetzt aber zum Glück Geschichte.

Share this post


Link to post
Share on other sites
vor 3 Stunden schrieb ronsei:

Ist irgendwie auch egal welche Einstellungen ich bei Schärfe und Denoise gesetzt habe, braucht immer gleich lange.

Das kann eigentlich nicht sein, weil ja je Verfahren anders entrauscht und entschärft wird. Ich meine, dass es unterschieldlich lange dauert, je nachdem ob AI Clear, Denoise oder Low Light anwende. Müsste ich aber auch noch mal mit Stoppuhr prüfen. Und immer mal wieder checken, ob die GPU noch angeschaltet ist.

Share this post


Link to post
Share on other sites
vor 5 Minuten schrieb cyco:

Das kann eigentlich nicht sein, weil ja je Verfahren anders entrauscht und entschärft wird. Ich meine, dass es unterschieldlich lange dauert, je nachdem ob AI Clear, Denoise oder Low Light anwende. Müsste ich aber auch noch mal mit Stoppuhr prüfen. Und immer mal wieder checken, ob die GPU noch angeschaltet ist.

Doch! Dem ist so. Mach mal eine Batchbearbeitung von mehreren (z. B 20) Fotos, und du wirst sehen, dass die unterschiedlichsten Einstellungen für Schärfung und Entrauschung pro Bild angezeigt werden, aber die Durchlaufzeit für alle (d.h. bis auf 1 Kommastelle) konstant ist. Jedenfalls beobachte ich dies so an meinem Rechner.

Edited by joachimeh

Share this post


Link to post
Share on other sites
vor 10 Stunden schrieb micharl:

... Bildelemente, wo keine sind, und vertut sich dann bei der Extrapolierung der Kanten. Dann gibt es häßliche Artefakte. Aber wenn sie richtig geraten hat, ist sie schon gut.

Ja, ziemlich genau das war es. Es wurden krisselige Säume erzeugt, wo vorher keine waren, obwohl ein eindeutiger hell-dunkel Kontrast von Motiv zum Hintergrund vorhanden war. Der Effekt war selbst mit minimalen Werten unvermeidbar. Links original - rechts preview aus dem jpg. Vielleicht ist es erkennbar. Es ist ein Foto aus der D750 mit 80200/2.8 bei gutem Licht, da wäre das gar nicht nötig gewesen. Im preview zwar etwas aufgeklarter, dafür aber mit Kantensaum, was man wohl normalerweise mit "defringe" entfernt. Das aber nur nebenher als nice to know. Für gelungene Fotos ohne derbe Fehler braucht man es nicht. Ich würde es von daher auch nur für Härtefälle nutzen, um sie überhaupt noch ansehnlich zu machen oder "Unikate" zu retten.

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb joachimeh:

Doch! Dem ist so. Mach mal eine Batchbearbeitung von mehreren (z. B 20) Fotos, und du wirst sehen, dass die unterschiedlichsten Einstellungen für Schärfung und Entrauschung pro Bild angezeigt werden, aber die Durchlaufzeit für alle (d.h. bis auf 1 Kommastelle) konstant ist. Jedenfalls beobachte ich dies so an meinem Rechner.

Hast Du unterschiedliche Verfahren angewendet oder das gleiche auf die alle Bilder? Ich meine nicht Einstellung, sondern AI Clear versus Low Light etc.

Edited by cyco

Share this post


Link to post
Share on other sites
vor 3 Minuten schrieb rostafrei:

Ja, ziemlich genau das war es. Es wurden krisselige Säume erzeugt, wo vorher keine waren, obwohl ein eindeutiger hell-dunkel Kontrast von Motiv zum Hintergrund vorhanden war.

Bei solchen Bilder sollte in der vorherige Bildbearbeitung möglichst nicht oder minimal geschärft werden. Ebenso sollte vorher keine Entrauschung stattfinden. Da bekommt man die besten Resultate in Denoise. Wenn vorher schon geschärft wurde, verstärkt Denoise u.U. diese Schärfung und es kommt so zu Artefakten.

Share this post


Link to post
Share on other sites
vor 8 Minuten schrieb cyco:

Hast Du unterschiedliche Verfahren angewendet oder das gleiche auf die alle Bilder? Ich meine nicht Einstellung, sondern AI Clear versus Low Light etc.

Bei Batchverarbeitung, d. h. wenn alle geladenen Fotos ausgewählt sind, bleibt es für alle für diesen Durchlauf beim anfangs ausgewählten Verfahren, nur die individuellen Einstellungen werden von der Automatik individuell bestimmt.

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb joachimeh:

Bei Batchverarbeitung, d. h. wenn alle geladenen Fotos ausgewählt sind, bleibt es für alle für diesen Durchlauf beim anfangs ausgewählten Verfahren, nur die individuellen Einstellungen werden von der Automatik individuell bestimmt.

Ok, probiere mal das gleiche Bild mit AI Clear und dann mit Low Light. Da müsste es Unterschiede geben. Ich bin gerade nicht am Heimrechner, sonst hätte ich das mal getestet.

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb cyco:

... Wenn vorher schon geschärft wurde, verstärkt Denoise u.U. diese Schärfung und es kommt so zu Artefakten.

Das wird der Grund gewesen sein. Das Beispiel war das allererste und einzige, was ich nach Freischaltung der Testversion ohne Sucherei auf der FP greifbar hatte - Ungeduld, nachdem es eigentlich geschafft ist 🤐  Interessant ist dann trotz allem, ob auch bereits endbearbeitete JPG sich damit noch etwas aufbrezeln lassen. Wobei dieses Programm wohl primär für RAW gedacht ist. Mich hatte das gestern in ersten Augenblick komplett verunsichert, bis mir dann schnell klar wurde, dass das Foto ja bereits fertig war. Wenn sich das als so universell herausstellt, bleibt für mich die Frage, wie ich das mit LR classic und der Nachbearbeitung später aufteilen werde. Große oder erhebliche Unterschiede konnte ich bei den Probedurchäufen zwischen ORF, NEF und DNG jetzt noch nicht feststellen. Aber ich habe das auch erst seit gestern und werde noch einige harte Nüsse damit zu knacken versuchen. Gelingt das, ist der Kauf beschlossen 👍

Zur Geschwindigkeit noch ein Wort:

Ich habe vorhin noch zwei schwierige low-light NEFs aus der D750 probeweise durchlaufen lassen. Da lief die Bearbeitung wesentlich schneller durch. Vermutlich weil ich mir einen bestimmten Bereich als Kontrolle herausgezoomt hatte, da ging es auch in 5-6sec mit split-screen. Dasselbe Foto auf die Arbeitsfläche angepasst in einem anderen Durchgang mit anderen Werten hat dann auch wieder deutlich >30sec für den kompetten Durchlauf benötigt. Das Speichern hat dann wieder ziemlich lang gedauert. Einen Stapel mit den gleichen Arbeitswerten werde ich trotzdem mal zum Vergleich verarbeiten, wer weiß, ob und wie weit mein Rechner in der aktuellen Zusammenstellung das mitmacht...

Edited by rostafrei

Share this post


Link to post
Share on other sites

Noch ein wahllos herausgegriffenes ORF - man muss wohl für jedes Foto die individuell passendsten Einstellungen finden. Stapel oder ganze Ordner würde ich nicht verarbeiten, auch bei identischen Aufnahme-/Kameradaten von einem Aufnahmespot.

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb rostafrei:

 bleibt für mich die Frage, wie ich das mit LR classic und der Nachbearbeitung später aufteilen werde.

 

Ich mach alles in LR fertig und ziehe nur den Schärferegler auf 0 - zu allerletzt bearbeite ich dann in Topaz...

Share this post


Link to post
Share on other sites
vor einer Stunde schrieb felix181:

Ich mach alles in LR fertig und ziehe nur den Schärferegler auf 0 - zu allerletzt bearbeite ich dann in Topaz...

Dito. Topaz ist bei mir auch der letzte Schritt und nur für wenige Bilder für den letzten Feinschliff.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Wir freuen uns über neue Mitglieder!

    Andreas, der AdminMein Name ist Andreas, und ich bin der Gastgeber hier. Wenn du Fragen hast, kannst du mich gerne jederzeit ansprechen!

    Wir haben eine Menge zu bieten:

    Wir freuen uns auf Dich! 

    Jetzt kostenlos registrieren!

    or Sign In

×
×
  • Create New...

Wir hatten schon den Sekt kalt gestellt und die Häppchen rausgeholt – es ist so schön und spannend, neue Mitglieder begrüßen zu dürfen…

Im Ernst: Wir freuen uns über neue Mitglieder!

Andreas, der AdminMein Name ist Andreas, und ich bin der Admin hier im Systemkamera Forum. Wenn du noch Fragen hast, kannst du mich gerne jederzeit ansprechen!

Wir haben eine Menge zu bieten:

Wir freuen uns auf Dich!

Jetzt kostenlos registrieren!